Post

1 follower Follow
0
Avatar

Can't receive calls on cellular data (app)

I'm having this problem with Textnow (otherwise great app), where I can't receive any calls while I'm on cellular data. I'm using a data-only plan with Public Mobile in Canada (runs on Telus towers), and I can make crystal-clear calls so the network speed shouldn't be a problem. However, whenever someone calls me, it would not ring on my side. After a few minutes, I would get a notification saying I missed a call. Same with texts - a long delay before receiving. It works flawlessly on WiFi and no problem with outgoing calls on data. I tried clearing cache and data, as well as reinstalling, to no avail.

I'm using Huawei Mate S, not sure if it's an optimization thing. I received no response from the customer support through ticket, I really hope this gets solved soon. Thanks!

Andy Wang

Please sign in to leave a comment.

1 comment

0
Avatar

Hi Andy, 

I'm sorry to hear about the issue! 

I'm glad you were able to go through the troubleshooting steps beforehand. At this point, it would be best to contact your network provider in regards to the connection. 

Let us know if you need further assistance! :) 

Tawny TextNow Support 0 votes
Comment actions Permalink